YarikR

YarikR

Пикабушник
поставил 2345 плюсов и 418 минусов
827 рейтинг 12 подписчиков 154 комментария 9 постов 4 в горячем
76

Ansible + Mikrotik = Приключения

Как и в любой сказке всё началось довольно невинно, захотелось мне сконфижить пачку микротов разом, через Ansible, и тут пошло всё не так)


Очень кратко, что это и как работает, можно прочитать ТУТ


Кратно о том что есть у меня в распоряжении для теста:

- Ansible AWX

- CCR1036-12G-4S


Глава первая - Печальная!

При попытке выполнить сценарий на свои продовых микротах, я получаю ошибку:

The error was: ansible.module_utils.connection.ConnectionError: timeout value 30 seconds reached while trying to send command: b'

* на самом деле дебаг больше и сочнее, но для понимания сути, будет достаточно этого)


1 - первое, что пришло мне в голову, это править таймауты в ansible.cfg - не помогло!

2 -  identity пользователя от которого выполняется сценарий, у меня это был ansible-ops.

* классический admin, был упразднен сразу же,  ввиду его не модности и не безопасности)

Забегая на перед, отчасти проблема была в имени пользователя, ansible с микротиком на пару, плохо понимают имена пользователей с дефисами. (Вернее не понимают совсем)

3 -  проведён ресёрч на тему длинны имени(Identity) самого Mikrotik, в процессе поиска, на  гите, была найдена ветка со схожей проблемой, решение было таково, что длина имени, не должна превышать 32 символа, у меня она составляла 30 символов, так что мимо кассы)

4 - были переустановлены несколько видов и версий прошивок, из ветки stable\long-term, не помогло

5 - на финал был скинут в ноль  CCR1036-12G-4S для теста, и... барабанная дробь, работает!


Глава вторая - победа, побед)

Проблема была обнаружена в имени Mikrotik, у меня они содержали пробелы и | (пайп лайны).

Дальше я решил проверить, а какие ещё символы Ansible + mikrotik на дух не переносят?

Какие символы в Identity Mikrotik, может переварить Ansible :

"test core router" - OK

"test-core-router" - OK

"test.core.router" - OK

"test:core:router" - NO

"test=core=router" - NO

Довольно важный момент состоит в том, что в имени пользователя от которого сценарий будет запущен, не должно быть дефиса(а возможно и других спец символов):

Ansible + Mikrotik = Приключения Mikrotik, IT, Network, Длиннопост
Ansible + Mikrotik = Приключения Mikrotik, IT, Network, Длиннопост

* ansible-ops = timeout!


Эта очень короткая записка о проблеме на которую я потратил неделю жизни и нервов)

Спасибо всем кто прочел, удачи и добра!)

Показать полностью 2
184

Тру Vpn за 4 бакса в месяц)

Привет, дорогой Пикабу!


Здесь произойдёт краткий(насколько это возможно) раccказ о том как я строил настоящий впн за недорого.


Как выглядит ТЗ:

– возможность создавать несколько учётных записей пользователей

– высокая скорость доступа (в рамках бюджета)

– безопасность данных (как настроишь, так и полетит)

– бюджет реализации 4$ :-)


Что мне для этого понадобится?

Совсем не много:

1. Хостинг провайдер с VPS, в моём случае это OVHcloud

(уважаемые читатели могут выбрать любой хостинг!)

2. Необходим облачный MicrotikCHR (Кликабельно)

3. VPS-сервер c предварительно установленной Ubuntu 20.10

4. Множко времени для настройки и тестирования


Процесс заказа VPS я пропущу, много бесполезной информации и куча лишних скриншотов!

Один важный момент связан с выбором локации хостинга VPS, чем дальше от меня сервер, тем выше латенси/ping, важно для онлайн игр, но в моём случае особой роли не играет.

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

После покупки VPS-ки мне на почту упало письмо с доступами в машине.

Залетаем в ssh, меняем сгенерированный хостингом пароль, добавляем свой публичный ключ для root, меняем hostname, обновляем, устанавливаем unzip перезагружаем.


На этом базовая подготовка VPS закончена, дальше интересней.

1 - Необходимо создать временный раздел для хранения образа MicrotikCHR

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост
mount -t tmpfs tmpfs /tmp/

2 - через wget скачать образ MicrotikCHR raw по ссылке, что приведена выше

wget https://download.mikrotik.com/routeros/6.47.9/chr-6.47.9.img...
Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

3 - распаковать скачанный архив


unzip chr-6*
Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

4 - просмотреть разделы на диске, это необходимо, для того чтобы знать на какой из их,  записать образ RoS CHR


fdisk -l

· в моём случае это - /dev/sda: 20GiB (Основной раздел диска)

· если ошибиться с выбором раздела, прийдётся вернуться к установке ОС и повторной первичной настройке

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

5 - Записать образ с помощью dd на нужный раздел

dd if=chr-6.47.9.img of=/dev/sda bs=4M oflag=sync

· if= то что ми пишем
· of= то куда пишем
· bs= размер блока записи
· oflag= опция дополнительных параметров, sysnc - дополняет сектора значениями NUL

6 - Перезагрузится, обычный reboot не сработает, потому:

echo 1 > /proc/sys/kernel/sysrq
echo b > /proc/sysrq-trigger

Дальше перехожу в веб-интерфейс хостинга и задаю пароль для пользователя admin через KVM (по умолчанию логин Mikrotik, admin без пароля)

/user set [find name=admin] password=SupeR_stronG_paSs-228

Параллельно добрые люди с ботами хотят взломать мой облачный роутер :-)

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

Дабы избежать неловких ситуаций, следует ограничить доступ к сервисам ssh, winbox , остальные отключить.


IP - Services

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

Теперь предстоит самое интересное, а именно настроить l2tp/IPSec


1. Ip - pool


– name : l2tp=pool

– addresses : 192.168.20.2-192.168.20.200

– next pool : none

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

2. PPP - Profiles / Создать профиль для l2tp туннеля


– name : l2tp-profile

– local address : l2tp-pool

– remote address : l2tp-pool

– DNS servers : 1.1.1.1 (можно использовавать любые)

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

3. PPP - Secrets / Создать профиль пользователя

– name : vpn-user001 (уникальность имён приветствуется)

– password : пароль умеренной сложности

– service : l2tp

– profiles : ранее созданный l2tp-profile

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

4. PPP - Interface - L2TP Server


– Enable

– default profile : ранее созданный l2tp-profile

– authentification : оставить только (mschap2)

– use ipsec : required

– ipsec secret : не самый простой Shared Secret

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

5. IP - IPSec - Proposals


– name : default

– auth algorithms : sha1

– encr. algorithms : aes-128 cbc / aes-192 cbc / aes- 256 cbc

– pfs group : modp 1024

· этот конфиг создается по умолчанию, но всё же стоит проверить ;-)
Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

6. IP - FireWall - NAT

· без nat, подключение произойдёт, но сети не будет

– nat rule : srcnat

– out. interface list : all

– переходим на вкладку Action

– action : masquerade

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

7. Простая настройка firewall


· буду приводить только консольные команды без скриншотов (ну ладно будет один финальный в конце ;-) )

· В терминале через winbox или ssh

/ip firewall filter

· добавить правила fasttrack connections

add action=fasttrack-connection chain=forward connection-state=\
established,related
add action=fasttrack-connection chain=forward connection-state=\
established,related protocol=tcp
add action=fasttrack-connection chain=forward connection-state=\
established,related protocol=udp
add action=accept chain=forward comment="FastTrack Connection" \
connection-state=established,related

· Правила для established, related + открыть порты для l2tp (500,1701,4500)

add action=accept chain=in connection-state=established,related
add action=accept chain=input comment="Port Access" dst-port=500,1701,4500 \
in-interface=ether1 protocol=udp

· разрешить ping (icmp)

add action=accept chain=in in-interface=etgher1 protocol=icmp

· остальное drop

add action=drop chain=forward connection-state=invalid
add action=drop chain=input connection-state=invalid
add action=drop chain=in
Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

8. получить лицензию на CHR

- Зарегистрироваться на оф.сайте Mikrotik

- Зарегистрировать CHR (после триального периода роутер не превращается в тыкву, если его не обновлять, продолжит работать на полной скорости даже после истечения лицензии)


system - license - renew license


- account : логин в учётную запись на Mikrotik.com

- passwrod : пароль от учётной записи на Mikrotik.com

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

А в личном кабинете видно временную лицензию

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

И на финал, тест скорости ;-)

Тру Vpn за 4 бакса в месяц) VPN, Mikrotik, Ubuntu, Linux, Гайд, Облачное хранилище, Длиннопост

Из минусов, не гигабит)


Крайне приветствую комментарии и предложения по теме!)

Показать полностью 17
18

Рефакторинг кухонного сервера и всё, всё, всё!

Привет, дорогой Пикабу, всё течет, всё меняется.

Мы начали больше работать дома, научились самоорганизации,  кто-то даже сменил работу)

В это не спокойное время, мне понадобилось больше производительности дисковой подсистемы, больше стабильности в плане электропитания, поболе разнообразных резервных копий.

И так с чего же начать, а нет zfs-а не будет,  я пересмотрел подход к созданию дискового массива и понял одну страшную вещь, что лепить насисадминеные диски не вариант, медленно и не надёжно, дешёвый блок питания любит голову, стабильный ребут всей машины каждый день.


Начало эпопеи можно прочитать тут тиць


Было принято волевое решение собрать десятый рейд...

*кратко что такое 10й рейд или другими словами 1 + 0, это по сути raid-0 из двух raid-1, быстро и отказоустойчиво(насколько это возможно)

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

В моём случае массив состоит из четырёх дисков 3,5 x 1tb, диски у меня разных производителей, но имеют одинаковый размер секторов и +/- одну скорость.

Каждый из дисков был промаркирован стикером (disk0, disk1, disk2, disk3),

в соответствии с портами на плате и утилите контроллера raid AMD RaidXpert2.

(Интерфейс утилиты Raid)

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Пример маркировки дисков:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Диски промаркированы не только  с торца как на фото, но и на верхней крышке, так и сбоку

Система была установлена на nvme ssd, а файловый архив и виртуальные машины перенесены на дисковый массив.

А вот и нет, недолго музыка играла, контроллер отказался нормально работать с nvme, система валилась в BSOD, переставил систему на массив, полёт нормальный, проблем не обнаружено.


Отдельно был приобретён диск для резервного копирования - Seagate SkyHawk HDD 2TB 5900rpm, хороший диск, тихий и холодный, то что нужно бекапов, хотя на рынке он позиционируется, как диск для систем видеонаблюдения.

Подключен диск через usb 3.0 карман Seagate...

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост
Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Немножко тестов скорости:

nvme ssd :

Был :-(

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Raid-10:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Диск под резервные копии:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Дальше были заказаны крепёжные стойки для HDD на Aliexpress, помимо стоек в корзину был брошен переходник\монтажная пластина sfx to atx.

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Пришло время замены блока питания, тут могла бы быть история о том что скупой платит дважды... но не будет.

Я откровенно зае... от постоянных ребутов, психанул и купил Silverstone Strider 500W 80+ Gold (SST-SX500-G)

Работает, аптайм стал постоянным.

Немножко о потребительских характеристиках БП, работает тихо, не греется в отличие от Vinga, максимальное потребление всей машины 194w.

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Сейчас несколько фото, в процессе сборки:

Собираю диски в стойку:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Монтаж блока питания на пластину:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Ну и фото до:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

И после:

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост

Не скажу что это всё было удобно монтировать, а разбирать, пока не хочу об этом думать)

Внутреннему перфекционисту стало немного легче,  но для полной красоты, нужно менять корпус.

С недавних пор у меня появились необходимость работы с Ansible и потребность тренироваться на кошках, в тестовой среде (или четверге),  Ха шутки за ... приведу краткий список штук:

- виртуалки RouterOS и Ubuntu, они же моя песочница

- начитавшись о dns over https, поднял pi-hole и запихнул его как dns всем клиентам своей локалки

- прикрутил redis к nextcloud +  развернул team-pass для хранения паролей

- rsync для бекапа конфигов, помимо регулярных копий штатными средствами винды

- sftp сервер для сбора конфигов из сетевых устройств, средствами ансибл.

- iredmail

- очень помогло аптайму сервера, отключение обновлений через sconfig, в вернее перевод в ручной режим обновления системы.

P.S. - Следующим этапом будет переезд на proxmox, и уход от Windows полностью.


Всем добра и спасибо, что уделили время!

Рефакторинг кухонного сервера и всё, всё, всё! Windows, Сервер, Компьютерное железо, Компьютер, Длиннопост
Показать полностью 15
13

Топ 10 Дэт-метал альбомов!

Конечно  топ версии меня,  подгорание пятой точки, судя по коментам читателей из моих прошлых постов, гарантирую!


Немного истории, вырос жанр из треш метала в лохматые 80-тые, по моим личным ощущениям на формирование манеры исполнения и звук повлиял Slayer,  а в 1987-м Death выпускает Scream Bloody Gore, вот тогда всё стало ясно.

Но не только death начали движение к более тяжёлому и экстремальному звучанию, там ещё и Possessed крепко заявил о себе альбомом Seven Churches,  после появились Obituary, Morbid Angel и много других трушных групп, всё стало злее, быстрее, тяжелее, несколько менее мелодично, но только на раннем этапе развития жанра.


Место № 10.

Не буду оригинален:

DEATH - Scream Bloody Gore

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Альбом сырой как любая ранняя работы начинающего коллектива, но он задал вектор развития жанра, что в последствии повлияет на всю тяжелую музыку в целом, пластинка уже стала классикой.

Место №9.

Bolt Thrower - смерто-метал её королевского величества!

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Последний альбом альбом группы выпущенный в 2005-м, это квинтэссенция того что Bolt Thrower, делатели всю карьеру, классический дэт-метал с современный звуком, профессионально сыгранный, великолепно звучащий!


Bolt Thrower - Those Once Loyal

Место № 8.

Hate Eternal - попадает сюда как представитель брудал-дэт.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

На данный момент последний студийный альбом Американцев, очень мощная работа, рекомендую к прослушиванию.

Hate Eternal - Upon Desolate Sands

Место №7

Rivers of Nihil - отличный представитель мелодичного и прогрессивного дэтха, Where Owls Know My Name, шикарная работа, саксофон лёг в микс так как будто так и должно быть.


Rivers of Nihil - Where Owls Know My Name

Место №6

Revocation - отличный модерновый техно-дэтх, качественно исполненный, скорость и техничность не ради скорости и грифодрочки.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Revocation - The Outer Ones

Место №5.

OBITUARY - одни из отцов жанра, их альбомы стали классикой, последний альбом прекрасен, потрясающие партии и гитары, четкий и размеренный ритм.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

OBITUARY - OBITUARY

Место №4.

Carcass - чудесный представитель мелодик дэтха.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Carcass- Surgical Steel

Место №3.

Deicide - тотальное бруталити уже ставшее классикой.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Deicide - Once Upon The Cros

Место №2.

Dethklok - чудесный проект от талантливого Брендона Смолла.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Dethklok - Dethalbum II

Место №1.

Тут трудно сделать выбор...

DEATH - работы Чака разделяю на два периода до Human и после, вторая половина мой фаворит, великолепно абсолютно всё, без исключения, а Control Denied - The Fragile Art of Existence самый прослушиваемый мною альбом в прошлом 2019-м году, но это уже не дэтх-метал вовсе.

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Моя любимая работа у Death и лучший death metal альбом!

DEATH - The Sound of Perseverance

P.S. тут не cannibal corpse, какой ужас и неуважение))))

Топ 10 Дэт-метал альбомов! Музыка, Хорошая музыка, Death Metal, Топ, Metal, Видео, Длиннопост

Не стесняемся, добро пожаловать в комментарии!

Показать полностью 10 10
18

Как я собрал nas и всё пошло не так!

Сетевое хранилище "здорового человека" выглядит примерно так:

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

Моё чудовище выглядит вот так:

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

Привет, более года я использовал самосборый ящик в котором жила старая материка на lga 775 и 4 гб озу ddr2, крутился там Centos 7, apache, nextcloud, transmission, plex media server, samba, webmin, zabbix и по мелочи.
Честно говоря старое железо проявило себя очень хорошо, после полного обслуживания, работало без сбоев, зависаний и прочего, наступил 2020 и я решил обновить платформу для новых свершений.


Прошлая конфигурация:

корпус DTS E-D5 Silver

плата asus p5q-vm

core 2 duo e8600 3.3 13$

4x- 1gb ddr2 667 mhz Hynix 8$

chieftec 400w gpa-400 s8

Arctic F12 TC

кулер на процессор vinga

Arctic F8 PWM CO

CHIEFTEC Thermal Killer 60mm

ssd goodram irdm 120

wd black 2.5" 500 )

wd blue 3.5" 500

toshiba 2.5" 500

WD Blue 1TB 7200rpm 64MB


В предыдущем железе не устраивало:
- нет рейд контроллера
- довольно горячая материнка
- sata 2
- не пригодность апгрейда

Не долго думая, платформой для апгрейда была выбрана AMD AM4.
Что было куплено нового:

Проц - AMD Athlon 200GE box
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

(Изначально процессор планировал совершенно другой, а именно ryzen 3400g, но он ушёл в другой пк и пришлось выходить из ситуации)


Мать - Gigabyte GA-A320M-H

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

Память - DDR4 dimm 16GB 2666Mhz (8 + 8) crucial/adata

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

Диски, блок питания, корпус, были оставлены от старой сборки.

И что же могло пойти не так? Да блин, всё!

По началу, захотелось приключений, принял волевое решение установить туда ESXI, для него не нужен отдельный диск, воткнул флешку и всё работает, не требовательность к ресурсам, простой и понятный центр управления.


Только вот на самом свежем билде гипервизора не завелась сеть, нормально так покурив форумов, сетку завёл на более поздней версии сборки, но тут внезапно возникла другая проблема, система не видела диски от слова совсем, этот косяк я не смог победить, нет драйверов на sata-контроллер, а про рейд и говорить не стоит.


Спустя целый день любовных утех с ESXI, на следующее утро решил ставить hyper-v server core 2019, тут всё прошло как по маслу и драйвера на рейд стали, сервак запустился, даже с Windows Admin Center я смирился, проработал на нём аж 5 дней.

Почему так мало? Очень тормозной админ центр, создать виртуалку и подключить к ней два виртуальных диска расположенных на двух разных физических дисках - боль, проще научиться садиться на шпагат.

* не хочу наговаривать на кор-сервер, здесь сказалась моя не опытность и не желание разбираться, в теме, не желание поднимать контроллер домена, для того чтобы управлять через оснастку hyper-v, самим серваком и тд.


По итогу, был установлен windows server 2019 стандарт, весь процесс установки описывать не буду, ничем не отличаться от обычной 10-тки.

Предварительно был обновлён биос, собран 1-й рейд из двух дисков 2,5 на 500 гб.

Система ставилась на ssd 120 goodram irdm, он, как и диск 3,5 на 1тб без резервирования.


Полное описание нынешнего конфига с ценами:

- корпус DTS E-D5 Silver - 37$

- блок питания chieftec 400w gpa-400 s8 - 30$

- TP-LINK TG-3468 гигабитная сетевая карта - 10$

- диски:

- adata xpg gammix s11 pro 256 gb 73$ (отстался от прошлой сборки пк)

- ssd goodram irdm 120 - 36$

- WD Blue 1TB 7200rpm 64MB - 44$

- 2.5" 500GB Seagate 2 шт - 50$

- процессор - AMD Athlon 200GE - 50$

- материнская плата - Gigabyte GA-A320M-H - 50$

- ОЗУ - DDR4 8GB 2666Mhz 2шт - 50$

- внешний диск в кармане под бекапы - Silicon Power USB3.0 Armor A30 500gb - бесценно (приклеен на двухсторонний скотч к корпусу).


Несколько живых фото сделанных на тапок:

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост
Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

В итоге, проект больше получился, чем потерпел фиаско, но и от изначальной идеи собрать простое и дешёвое сетевое хранилище не осталось и следа.


Тестовая среда выполняет свои задачи, тут и Plex, Nextcloud, docker, zabbix, postfix, samba, transmission, песочница тащит, удовлетворяет все мои хотелки, благодаря ему могу изучать докер, sql, тестировать новые для себя технологии.

Как я собрал nas и всё пошло не так! Nas, Сервер, Windows, AMD, Am4, Компьютер, Длиннопост

Постараюсь наперед ответить на  вопрос, зачем оно надо если я могу в амазоне\ажуре все сделать и не любить голову собирая конструктор у себя на кухне!


На сборку ящика меня очень давно вдохновил Ютюб, а именно Дима Бачило, блин, да этот чудак мотивировал меня сменить работу, а в последствии и сферу деятельности, огромное спасибо Диме за то что он делает!

А любовь к железу у меня появилась ещё в школьные годы, когда мы с пацанами крутили печку чтобы у меня запустился первый ассасин, это хобби которое со временем переросло в профессию.


Господа Пикабушники, спасибо что прочли мою писанину до конца, очень жду фидбека в комментариях, ещё раз спасибо!

Показать полностью 13

Пост боли и страданий)))

Вроде банальная история, но такого эпичного объявления я ещё не видел.

Пост боли и страданий))) GTX, Amd Radeon, Olx, Авито, Покупка

Всем удачных покупок)

-27

10 лучших рок-метал коллективов Украины!

Привет, пишу свой, очень субъективный список коллективов, да это не топ, а просто список групп.

Коллективы очень разношёрстные, тут и metalcore, death, gothic, rock, часть банд появилась здесь сугубо из ностальгии, что-то услышал только недавно, что-то слушаю с университетской скамьи, что же, поехали!

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

HELL:ON- познакомился с их творчеством давно, было это в 2009-м году.

Первое что пришло в голову это Pantera, Sepultura, на тот момент мне порвало шаблон, мол это сделано в Украине, сирисли?

ДА, серьезно, суровый треш, прямой и брутальный, техничный (по поводу техники исполнения, в уже 2020-м году играть быстро и плохо просто нонсенс, по этой причине пишу об этом первый и последний раз).

Приведу пару песен за разный период.


Hell on - Wake Up! 2008

https://www.youtube.com/watch?v=njuIH6GMjbQ


HELL:ON - Ashes Of The Gods 2019

https://www.youtube.com/watch?v=UyHHLVbaq_c

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Nokturnal Mortum

По моему мнению лучший блек-метал коллектив Европы, а ведь это ещё фолк и паган.

История группы началась ещё в 1991-м, многое с того времени изменилось и мне очень нравиться эти изменения.

Хочу выделить два последних альбома

Голос сталі (2009)

Істина (2017)

Мелодично очень!, тяжело, тематично.

Скину сразу силку на альбом Істина (2017)

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Drudkh - более блэк-металично чем Nokturnal Mortum, мне показалось что они тяготеют больше к норвежскому так сказать звучанию, а с течением времени приобрели больше мелодичный оттенок.


Їм часто сниться капіж (They Often See Dreams About the Spring)

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

FLESHGORE - дэтх подъехал, когда первый раз услышал, даже не представлял что это мои соседи). Киевская группа, брутально, профессионально, звук плотный как стена, настоящий дез!


Альбом 2017го Denial of the Scriptures, приведу одну из песен.

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Полинове Поле - прошло много времени я того момента как я слушал этот коллектив, спустя 11 лет, наткнулся на новую работу и был приятно удивлен, что коллектив ещё существует, выступает, и в 2017м записали альбом.

Это готик-метал с примесью дума, верните мой 2007й, очень заходит женский оперный вокал, брутальный гроул, нравиться лирика, и последняя запись очень серьезная.


On The Edge Of The Abyss 2017

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

JINJER - не знаю что тут написать, они добились успеха и мирового признания, подписаны на Napalm Records, выступают на топовых фестивалях мира.

Это такая смесь метал-кора с грувом и чертовски милой Татьяны, как по мне слишком молодёжно))). Честно сказать для меня, звук слишком правильный, вылизанный, нет в нём индивидуальности, дико вытаскивает вокалистка.


Слушать лайв из Вакена 2019

И студийку Pisces

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Morphine Suffering - это типичный метал-кор, его бы здесь не было, но есть одно, но, хлопцы великолепно в живую играют, энергетика, драйв, всё тут есть.


Для меня это лучшая метал-кор банда Украины.

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Stoned Jesus - это вообще победа, не из гладимое впечатление на меня произвел альбом Seven Thunders Roar 2012 и производит до сих пор, все их работы мирового уровня.

Стоунер-рок\метал, тут и мастодон близко, Black Sabbath-а мотивы я услышал, потрясающий альбом The Harvest 2015.


Приведу силку на I'm The Mountain из альбома Seven Thunders Roar.

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Somali yacht club - Много стоунера не бывает!

А если серьёзно, крутой Львовский коллектив, звучание более роковое чем у Stoned Jesus.


Альбом The Sea 2018

10 лучших рок-метал коллективов Украины! Metal, Тяжелая музыка, Топ 10, Украина, Музыка, Видео, Длиннопост

Merva - кто они такие? Это очевидно не Океан Эльзы, Друга Ріка и ещё много хороших рокешных групп.

История началась в далёком 2009м году когда я учился в коллеже, студентам раздавали журналы о популярной культуре, где писали о кино, музыке, гаджетах, и прочих,  очень нужных на тот момент вещах, в одном из выпусков я прочитал интервью коллектива Merva.

Merva(Видение) - ранее творчество более походило на метал-кор тех лет, промежутка 2005 - 2010, спустя 10 лет я услышал альбом 2015го І-Цзин, это откровение, глубокая лирическая работ, шикарная роковая пластинка, трек Відпусти, поглотил меня на месяц.


Без лишних слов.

Итог, спасибо что смогли осилить мою писанину и вкусовщину до конца, возможно кто-то смог найти для себя что-то интересное.

Показать полностью 10 10
436

Пусть новый год принесет Вам больше радости и новых открытий

Что ещё нужно сисадмину? Термопаста с мандаринами в прикуску.

Пусть новый год принесет Вам больше радости и новых открытий Amd ryzen, Nas, Новый Год
23

Топ 5 метал альбомов 2019го года!

Привет, излагаю сугубо своё мнение, не совпадение с вашим гарантирую, 2019-й удался на релизы, много всего было интересного, постараюсь изложить кратко.


Ниже будут описаны 5 пластинок, от разных коллективов, которые меня смогли впечатлить, кое-что ждал, одни меня поразили и удивили, список будет составлен наименее меня зацепившего до записи вызвавшей у меня эмоциональный катарсис, поехали!

Топ 5 метал альбомов 2019го года! Музыка, Metal, Первый пост, Топ, Видео, Длиннопост

5) Killswitch Engage — Atonement


Не знаю что эта метал-кор банда пыталась «Искупить», но всё у них получилось, честно говоря, думал что, перерос жанр, но хорошую музыку перерасти нельзя.


Альбом славный, мелодичный, много чистого вокала, крутые припевы, звук мне напомнил Lamb of God, а может показалось ;-), ровная коммерческая пластинка, слушать приятно, затянуло, не отпускало неделю, два вокалиста люто тащат!


Весь альбом лежит на Youtube, правда не одной записью, приведу ссылку только на заглавную песню.


https://www.youtube.com/watch?v=2N0ShfOOEq4&feature=emb_log

Топ 5 метал альбомов 2019го года! Музыка, Metal, Первый пост, Топ, Видео, Длиннопост

4) Whitechapel — The Valley


Меланхолия... это подходящее слово, я смог раствориться в этой безысходности на 40 минут, талантливо, коллектив который начинал как дет-кор, запилил шикарный грувовый альбом, очень взрослая работа.


Особенно хочу выделить композицию Black Bear, бас партия сделала всё чтобы эта запись оказалась тут!


https://www.youtube.com/watch?time_continue=2&v=q4yXHXJO...

Топ 5 метал альбомов 2019го года! Музыка, Metal, Первый пост, Топ, Видео, Длиннопост

3) Cattle Decapitation — Death Atlas


Вот просто люблю дет-метал, конечно пост о музыке, но сначала упомяну обложку, атлант что держит погибающий земной шар, и время его уходит, монументальная работа художника, браво!


Бласт биты, надо больше бласт битов!


А если серьезно, это шедевр среди death релизов этого года, тяжело, технично, Вокалист, он делает вещи, такого уровня вокала я ещё не встречал.


Пластинка мелодичная, драйвовая, альбом наполнен тематически, подниматься вопроси судьбы человечества на пути к прогрессу, но всё это меркнет перед главной составляющей, музыкой!

Топ 5 метал альбомов 2019го года! Музыка, Metal, Первый пост, Топ, Видео, Длиннопост

2) Tool — Fear Inoculum


Tool — это Pin Floyd 21-го века! Не претендую на истину в последней инстанции, для меня это самый вкусный прог из всех что я слышал.


Я ждал этот альбом с трепетом, как встречи с любимой девушкой, как вёсны после трудной и холодной зимы, волнуясь и размышляя, а сможет Tool превзойти себя после 10,000 Days.


Всё вышеописанное слишком субъективно, это лучший прог-метал альбом последней декады лет, и всё тут, надо слушать, Tool, такой коллектив, в материал которого надо «въехать», проникнуться, почувствовать и он вас больше не отпустит!

Топ 5 метал альбомов 2019го года! Музыка, Metal, Первый пост, Топ, Видео, Длиннопост

1) Motanka - Motanka


Мотанка... Начну с того что в Украине есть сильная метал сцена, об этом я напишу материал отдельно, но одноимённый альбом группы Мотанка разорвал мой шаблон, ух, насколько это было приятно!


Этно -метал, так я хочу назвать то, что услышал здесь, много народных инструментов, все использовано мастерски и к месту, шикарный чистый вокал, до мурашек пробирают припевы, тематика.


Альбом тяжёлый, густой как смола, ты его пьешь, а напиться не можешь, все 56 минут меня не покидало ощущение, что я дышу вместе с пластинкой.


Качает, лирические интро, много струнных, шикарные рифы, стихи, а главное что это своё, родное!


Вот он, мой личный альбом года, а ведь до не давнего времени это место занимал Tool.


Особенно хочу отметить песню Verba, слушать громко и с понимаем дела).


Спасибо, что прочли, буду рад замечаниям и дискуссии в комментариях, почему всё должно быть иначе)

Показать полностью 5 5
Отличная работа, все прочитано!