-15

Эксель мастера призываю вас.

Короче говоря, есть три единообразные таблицы в экселе идентичные в части шапки (одинаковые столбцы) но с разным наполнением.

Есть ли какой- то простой способ объединить три таблицы в одну с удалением дублирующихся в разных таблицах одинаковых строк. Одинаковость строк это 100% совпадение строк.

Да-да Пикабу не место для вопросов и гугл у меня забанили и вообще это развлекательный ресурс)
10 коментов для минусов всем тем кто согласен))

Дубликаты не найдены

+1

Пока на ум приходит только топорный вариант:

Скопировать все на один лист, после последнего столбца сделать формулу сцепления всех предшествующих значений.

Например есть 3 столбца, тогда в столбце D формула:

=СЦЕПИТЬ(A2;B2;C2)

Потом, в следующем столбце:

=СЧЁТЕСЛИ(D:D;D2)

и эту формулу протянуть на все значения

Строки встречающиеся 1 раз, будут иметь значение 1.

Соответственно фильтр, убрать значения с 1, останутся только повторяющиеся, удалить их, удалить служебные столбцы.


Решение топорное и не универсальное.

Если нужно более универсальное значение и данные меняются при этом надо удалить повторяющиеся значения, а уникальные оставить на исходных листах - думаю без макроса на обойтись. Тут вопрос времени, макрос не очень сложный.

+1
Вкладка 'Данные' - 'Удаление дубликатов'.
раскрыть ветку 6
0

Удаление дубликатов, оставит из дубликатов один вариант.

например:

1

1

2

после удаления дубликатов останется:

1

2


Как я понял ТС нужно удаление вообще всех значений которые повторяются.

раскрыть ветку 5
-1
Просто кто-то не умеет пользоваться удалением дубликатов.
В окне нужно выбрать все повторяющиеся столбцы, чтобы

1 2
1 2
1 3
2 2
2 2
2 3

Превратилось в

1 2
1 3
2 2
2 3
раскрыть ветку 2
-2

именно

раскрыть ветку 1
0
Дрочи своей головой
0
разве нельзя таблицы сцепить в одну, далее:

данные - фильтр - расширенный фильтр и включить чекбокс "только уникальные записи". Копируем результат и переносим на чистый лист.

0

делается очень просто через оператор "если" только не понятно что должно получиться в итоге, смотри если строки совпадают то выводиться значение какой либо строки,а вот если не совпадают что выводить в таком случае?

0

за бабло?

раскрыть ветку 5
-2

если надо за бабло, то за бабло)
во сколько вы оцениваете такую работу?

раскрыть ветку 4
-1

рублей 500 :)

раскрыть ветку 3
-1

минус8

-1

минус7

-1

минус6

-1

минус5

-1

минус4

-1

минус3

-1

минус2

-1

минус1

-2

минус9

-3

минус10

раскрыть ветку 2
-1
Маловато для минусов. Еще давай.
раскрыть ветку 1
0

вам поставил до кучи)

Похожие посты
Похожие посты закончились. Возможно, вас заинтересуют другие посты по тегам: