-5

Хочу попросить помощи у тех кто отлично разбирается в компьютерах.

Решил я поиграть в SA-MP, скачал GTA San Andreas и при запуске возникло аж 2 ошибки:

"Windows не удалось применить требуемые изменения.

В качестве параметра указано не допустимое имя компонента Windows.
Код ошибки: 0x800F080C".

И ещё ошибка:
"Grand Theft Auto SA requires at least DirectX version 9.0".

Много гуглил, видел разные способы, мол установите последний DirectX, .net Framework.

Скачал DirectX с сайта Microsoft, нажал установить и написано:
"Более новая и эквивалентная версия DirectX уже установлена. Выполнять установку не требуется".
Окей, идём дальше, скачал .net Framework 4.5 с сайта Microsoft.
При установки такой текст:
"Майкрософт .NET Framework 4.5 уже является частью этой операционной системы. Установка распространяемого компонента .NET Framework 4.5 не требуется.

На этом компьютере уже установлена та же или более новая версия .NET Framework 4.5."

Так же, ставил совместимость GTA SA на: Windows XP (Сервис пак 3), Windows 7, Windows XP (Сервис пак 2), Windows 98 / ME.
Тоже не помогло, дальше нашёл другой способ это по пути:
Панель управления->Программы->Программы и компоненты->Включение или отключение компонентов Windows.
Зайти и включить компонент DirectPlay (Компоненты прежних версий->DirectPlay), но у меня нету вкладки "Компоненты прежних версий" и соответственно нету компонента "DirectPlay".

Также скачал все обновления Windows 8.1 через "Центр обновления Windows", ничего не помогло.
Переустанавливать Windows не вариант!

Что делать, нужна помощь!

Дубликаты не найдены

+1
У меня на восьмерке san andreas не запускалась под предлогом ошибки directX (как и у тебя). После долгих мучений плюнул, достал болванку с windows 7, установил. Пошла)
+1

в компонентах windows в legacy componets
этот ебучий директ плэй там

0
Написал бы на форум, не знаю
раскрыть ветку 1
0
Написал на множество форумов, на гугл ответы, майл ответы, везде, но пока никто не помог.
0
То что .net framework 4.5 уже есть в ОС 8.1 совершенно не значит, что там есть и .net framework 3.5.

Поэтому смело идем в панель управления -> программы -> Программы и компоненты -> Включение или отключение компонентов Windows -> .NET Framework 3.5 (включает в себя чего-то там). (Просто жмакаем на галочку, чтобы появился квадратик, внутрь не лезем) -> ОК -> Ждем пока поставится, перезагружаемся, пробуем.
раскрыть ветку 1
0
http://i.imgur.com/zNepge2.png

У меня .NET Framework 3.5 ни на что не разделяется.
0
это не пробовал? http://otvety.google.ru/otvety/thread?tid=2cddbd1e7fa593c9
режим совместимости не помогает?
раскрыть ветку 1
0
И это пробывал и режим совместимости, ничего не помогает. Я с 11 часов по МСК сижу над этим почти без перерывов, и я думаю всё что есть в гугле я перерыл.
0
Переустанови игру, спросит ставить Directx соглашайся у меня много игр просили при установке все ставил, когда не ставил те же проблемы были
раскрыть ветку 11
0
В установщике GTA SA есть кнопка "Install DirectX 9", но при нажатие на неё выдаёт ошибку типа: "Эта версия DirectX не совместима с используемой версией Windows."
раскрыть ветку 10
0
Ну не знаю тода, попробуй отдельно 9 вставить
раскрыть ветку 9
0
Может GTA v1.1?, нужна 1.0
раскрыть ветку 1
0
У меня скачана GTA SA 1.00.
-1
1. можно разбить жесткий на два раздела и на один из них накатить винду любую
(или если есть второй жесткий, то на него)
(или на usb-флешку подходящего объема)

2. можно, если позволяет железо, установить виртуальную машину, на нее винду любую, а дальше уже понятно
(это для извращенцев ;D и тормоза скорее всего будут, если вообще будет играбельно )
раскрыть ветку 1
0
1. Не вариант.
2. Об этом задумывался, но это уже совсем на крайний случай :D
Похожие посты
Похожие посты закончились. Возможно, вас заинтересуют другие посты по тегам: